Prospect cannot finish ID/Selfie verification during registration
Resolved·Partial outage

Issue is confirmed resolved now

Wed, Feb 4, 2026, 09:11 PM
(1 week ago)
·
Affected components
Updates

Resolved

Issue is confirmed resolved now

Wed, Feb 4, 2026, 09:11 PM

Monitoring

Vendor has fixed the issue and now monitoring the performance

Wed, Feb 4, 2026, 08:55 PM(16 minutes earlier)

Identified

Issue reported that prospects cannot finish Rently account registration due to ID/Selfie cannot be verified, which due to verification vendor facing an issue, who is working on the fix

Wed, Feb 4, 2026, 08:06 PM(48 minutes earlier)
Powered by

Copyright 2026 Rently. All Rights Reserved.