Copyright 2026 Rently. All Rights Reserved.
Resolved
ILS data has been recovered, label this issue as resolved
Monitoring
All missing Rent.com leads have been restored
Identified
All missing Zillow leads have been restored
Investigating
There was an incident happened between Mar 20 12:18PM UTC and Mar 23 4:40PM UTC that inquiry leads missed in Rently from ILS partners
Mar 23 4PM UTC Incident reported to Dev Team
Mar 23 4:40 PM UTC Incident resolved
Mar 23 5 PM UTC Started working with ILS partners on recovery of those missing leads