Copyright 2026 Rently. All Rights Reserved.
Resolved
Issue has been resolved
Identified
Sim Card Provider has identified the issue and now working on the recovery, will provide another update within next 2 hours
Investigating
We are currently experiencing a service degradation where Rently Smart Hubs have partially gone offline. This issue is due to a degradation in service from our SIM card provider. We are now working closely with the provider to get this resolved