Copyright 2026 Rently. All Rights Reserved.
Resolved
Issue resolved, all emails sent as expected
Monitoring
Issue has been resolved by switching to backup email provider
Investigating
Rently emails are not sent to prospects/property managers, while sms and webhook are still working, now we are working on resolution.